Home > Why Do > Why Do I Need .net Framework 3.5 When I Have 4.0?

Why Do I Need .net Framework 3.5 When I Have 4.0?

What type of applications use this framework? While the platform was ostensibly designed to support hardware other than Windows-based PCs, however, its proprietary nature led to it mostly being used for Windows applications. The versions were intended to be backwards-compatible (so an application written for version 2 could run if version 3 was installed), but that didn't work out so well. share|improve this answer edited Mar 4 '11 at 7:04 answered Mar 3 '11 at 10:45 harrymc 197k7178432 You're wrong about .NET 4 being built on top of 2.

The latest release is entirely standalone and does not require previous versions. share|improve this answer edited May 12 '14 at 19:33 answered Mar 3 '11 at 14:14 Matthew Steeples 1,9101122 2 -1 If you have .NET 4 you can run any app Magic the Gathering: Friends or Foes? JOIN THE DISCUSSION (11 REPLIES) Got Feedback? http://stackoverflow.com/questions/2642301/do-you-need-both-net-3-5-and-4-0-installed-or-just-net-4

We do not recommend running apps that target a later version of the .NET Framework on the an earlier version of the .NET Framework. Despite installing the latest Intel Drivers for G41 chipset The error would persist. Microsoft has created other implementations of .NET to help resolve this. Reply Saradhi says: February 10, 2014 at 7:27 am i too had 2.0,3.0,3.5 in my xp with sp3.

Try removing them from here, through the standard uninstall procedure, then try installing your newer .NET framework again. It is mostly backwards compatible so it is possible to get your old applications to work on it. When you are install an application that needs a specific version of framework you can download them . (They will mostly be needing 2, 3, or 3.5) share|improve this answer edited flavallee replied Mar 17, 2017 at 7:47 PM Loading...

The biggest is portability. This means that you can install the .NET Framework without having uninstall previous versions. You have not mentioned .Net 4.0, but with this version Microsoft has tried to reduce the size of the software by not including all the previous versions. .Net 4.0 is therefore That statement is just hearsay. –Aaron McIver May 18 '12 at 4:06 add a comment| up vote -2 down vote If you have .NET 4 installed you can run any .NET

Loading... Users benefit from consistent applications and also the fact that many apps might not be developed at all if the developers didn't have access to the framework. It's always worth a shot. I wish I didn't need the older versions, though. :(.

Unless you're a developer, you don't need a lot of knowledge to make use of it. If you don't end up seeing any error messages like this, then you don't need to worry about re-installing the .NET Framework 1.0 or 1.1. This is just MS marketing hype. –harrymc Mar 3 '11 at 16:33 | show 7 more comments up vote 5 down vote Different applications need different frameworks and I guess there If you try to uninstall the .NET Framework 2.0 or 3.0 when the .NET Framework 3.5 is installed, their uninstall processes will block and tell you that they are needed by

Recently I had some big problems with Windows 8 - it came to a grinding halt (after being lighting fast for 6 weeks) One of my suspicions is that .net 3.5 i downloaded manually 1.0 and left it. Reply Robert Feal-Martinez says: March 27, 2014 at 2:52 am Hi Aaron, Came across this thread because having trouble .net 2 hogging CPU. So...

This is where it starts to get interesting! .NET 3 was introduced (along with a service pack to .NET 2) and was an additional set of libraries to it. .NET 3.5 Join over 733,556 other people just like you! RELATED ARTICLEHow to Scan for (and Fix) Corrupt System Files in Windows First, you should make sure that Windows has all its latest updates. That said, if you are having troubles that you think are related to the .NET framework, there are a few steps you can take.

The .NET Framework is not an application, it is a framework used by applications. Do Windows and Office need this old version for themselves? If you end up seeing any error messages like this, you can re-install the .NET Framework 1.0 or 1.1 in order to resolve the errors.

In this case, the attempt to run the application will fail. –pepoluan Sep 6 '13 at 12:29 1 -1.

So stop believing MS employees incompetent BS they feeding us last 20 years. Round the string What is the origin and meaning of "to be a square"? Determining if a set is a Basis for l^2 A multiplication algorithm by Paul Erdős: how does it work? BEST OF HOW-TO GEEK Mirror Your Computer's Screen on Your TV With Google's Chromecast How to Send and Receive Faxes Online Without a Fax Machine or Phone Line Reduce Eye Strain

Is my Samsung Smart TV vulnerable to the "weeping angel" attack? Each version is built incrementally on top of the earlier versions. As there are very few products left that require .Net 1.1, one can wait with its installation until there is a real need for it. Secondly, upgrades to the .NET Framework finally started being delivered through Windows Update.

Reply Anonymous says: March 27, 2012 at 3:14 pm Great answer, Thanks! Add in all the C++ redistributables & the machine I'm looking at now has over 15 instllations just from .net & C++. If I am building an app targeting the .NET 2 platform for whatever reason I am certainly not shipping .NET 2 redistributable...I am shipping .NET 4. –Aaron McIver Mar 3 '11 The good news is that you as a user don't really have to worry about those installations anymore.

I say nothing about v4, since I have no experience with it. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed In most cases, that means you do not need to keep the .NET Framework 1.0 or 1.1 installed on your system if you already have the .NET Framework 2.0 installed. The bits of code in the shared library can perform all kinds of different functions.

Like another astute commented stated above, if you have dependencies for 3.5.1 that can't be transitioned, choices are a bit more limited. Reply B says: July 25, 2012 at 8:18 pm Completly agree with the other posters, in that it should be more like Java. Who is the oldest character in Harry Potter? To cover their hide they have to propagate that information.

Apps written to versions 3.5 and lower will require version 3.5 to be installed, and apps written to version 4 or higher will need version 4 installed. Blue region in satellite image Positive sectional curvature does not imply positive definite curvature operator? You have options for adding version 3.5 and version 4.6 separately. with MOSS2K7, SP2010 services may be fun... ;-o share|improve this answer edited Jan 4 '13 at 0:59 answered Jan 4 '13 at 0:51 user1947213 11 CLR 4.5 does not

Yes No Additional feedback? 1500 characters remaining Submit Skip this Thank you!